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Foreword
Dimensions Expert is a dedicated tool for automatic triangle model repair and 
splitting. Dimensions Expert repairs errors, like gaps, inverted normals, duplicate 
triangles etc. in STL files and allows outputting correct STL data for 3D Printing. 
Also, large models can be split to fit into smaller work spaces as well as for faster 
build. 
The  Dimensions Expert  8.1:  Quick  Start  Guide  document  provides  an 
introduction to  the  basic  3D model  handling  with  Dimensions Expert:  triangle 
model repair and model splitting with Dimensions Expert Software.  The  Quick 
Start Guide document and the geometry files for the  examples are found in the 
Tutorials folder and its sub-folders in the Dimensions Expert installation directory. 
There are two simple lessons and it should not take more than 15 minutes to go 
through the examples. 
The first lesson fixes an erroneous STL model for 3D Printing using the Auto 
Repair process available with Dimensions Expert.
The second lesson  describes methods to split  and combine STL parts for 3D 
Printing. Large parts must be split and pins have to be added to be able to attach 
the manufactured parts correctly. 
DeskArtes  Expert  Series  software  suite  consists  of  several  products:  View 
Expert, Design Expert, 3Data Expert and Dimensions Expert. The View Expert is 
targeted for viewing,  verifying,  dimensioning and communicating 3D geometry 
information.  The 3Data Expert  is  used for  manipulation of  3D data,  including 
surface  triangulation,  STL  repair  as  well  as  coloring  and  modification,  like 
offsetting and boolean operations. Dimensions Expert is a dedicated tool for STL 
repair and splitting for machines with a smaller build area. Design Expert is a tool 
for free form conceptual design. 
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Lesson 1 – Fully Automatic STL fixing 
This lesson shows you how to fix an erroneous STL model for 3D Printing using 
the automatic tools with Dimensions Expert. Before starting the lessons please 
make sure you have received and installed the software license from DeskArtes. 
If you do not have a license yet, it is very simple to request an evaluation license. 
First go to the Help > About Dimensions Expert command dialog. There you can 
find the Send E-mail button (in green circle below). Press it and it will open your 
favorite email application to send the license request to DeskArtes. 

You will receive the 30 days evaluation license within 24 hours. When the license 
arrives, please Copy/Pate it into the appropriate field in the Help About dialog. 
Then press OK and restart the software. 

Auto Repair process for STL files

When  inputting  a  triangulated  model  into  Dimensions  Expert  an  automatic 
analysis and repair process is started. In normal everyday use you can verify and 
correct most of the models using the Auto Repair process. 
First open the dino-connected.stl file in the Tutorials/GeomFiles directory with 
the File > Open command. Make sure the Files of type is STL:
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Press Open to bring the model into the software. You will be prompted for the 
units, accept the proposed units Millimeters:
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Press  OK to  continue  and  you  will  be  prompted  for  the  Operation  Mode. 
Dimensions  Expert  has  three  main  operation  modes:  Fix  Model,  Print  
Preparation and  basic  View  Model mode.  The  different  modes  are  used  for 
different tasks:

● Fix  Model takes  you  to  automatic  model  verification  and  repair,  and 
contains shortcuts to the main tools used for repair work; 

● Print Preparation shows tools for model manipulation, such as hollowing 
and splitting. These tools also check the model for errors; 

● View Mode allows you to temporarily view the model and then return to 
Operation Mode selection. 

The normal way to begin repairing a model is to start with the Fix Model mode. 
To start fixing  press the Fix Model button in the Operation Mode dialog now. 
Dimensions Expert will  begin automatic model verification (Fix Model > Verify 
Shells command). The screen is erased and a progress bar appears. When the 
analysis is ready, a Model status message box is displayed
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The message indicates that there is one verified shell, which also contains errors. 
The display shows red Gap curves through the surfaces. Gaps are an error type 
you must fix during the repair process. 
The model is divided into separate shells during verification. In this case we only 
get one shell. Press the OK button in the Model status dialog to see the model 
structure in the  Model Tree (on the left-hand side of the image that follows) as 
seen below.  The error shell  has red icon (and the correct  shells  would have 
green icons) in the Model Tree. 
The  Fix  Model  Tab on  the  Tools  Window  (on  the  right-hand  side)  provides 
shortcuts  to  the commands available  for  repair.  The  Help text  window at  the 
lower part of the Fix Model Tab also contains information for repair actions. 
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Auto Repair is the best path to follow when repairing everyday models so press 
the OK button to initiate Auto Repair. Auto Repair will attempt to fix all shells 
with errors in the Model Tree. When you only have one shell you should always 
try Auto Repair first. 
When  Auto  Repair  is  started  each  shell  is  run  through  the  automatic  repair 
command (Fix Model > Repair Shells  command) using automatically calculated 
parameters.  For each shell,  a progress bar shows the progress of the repair. 
After the Auto Repair process  the following message is displayed: 

You will now receive the final status report.  Press the OK button to close the 
Model status window, containing the final status report, after Auto Repair. 

A  Tip  Window with  useful  tips  on  viewing  and selection  mechanisms is  also 
displayed after Auto Repair. After reading the tip you can Close the tip window:
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During the Auto Repair, Dimensions Expert attempts to fill all gaps and remove 
non-manifold  triangles  (overlapping  triangles,  multi-edge  triangles,  duplicate 
triangles, triangles having less than three neighbors, etc.) from the model. To see 
more about triangle errors, please access the “Triangle errors” page in the Online 
Help chapter “Handling Faceted Models”. The dino-connected.stl model only has 
simple errors, like inverted triangles and gaps, which are all fully repaired during 
the Auto Repair process. You can now continue to save and print the model, as 
indicated by the status information in the Fix Model Tab Help Text window. 

Basic viewing commands

You  have  just  fixed  your  first  model  with  Dimensions  Expert.  Now  try  the 
following commands to become familiar with viewing operations. Note that the 
commands below do not alter the model’s true 3D coordinates. They only alter 
the eye-point location: 

● Rotate the model on the screen by pressing the middle mouse (MMB) and 
moving the cursor. Left mouse button (LMB) rotation is also available most 
of the time except when working with painting, texturing, curve editing, and 
transformations. 

● Rotate the model around a selected surface point by pressing the  right 
mouse button (RMB) and moving the cursor. A blue cross indicating the 
rotation middle point appears on the part surface if the cursor is on top of 
the model when the RMB is pressed.

● Pan the model by dragging with the MMB (or LMB most of the time) while 
pressing the Shift key down.
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● Pan with rubberband by dragging with  RMB while pressing the  Shift key 
down.

● Zoom in/out by rotating the mouse wheel.
● Zoom in/out with MMB (or LMB) while pressing the Ctrl key 
● Zoom to box with RMB while pressing the Ctrl key 
● Hide all by pressing the       icon with LMB (or F5)
● Show all by pressing the        icon (or F6)
● Fit the model by pressing the       icon (or F7).

The main viewing command icons reside in the Viewing Toolbar:

Try them out now. The tooltips provide a short description of each icon (let the 
cursor remain on top of  the icon for a couple of  seconds to see the tooltip). 
Please  note  that  some  icons  will  perform  slightly  different  operations  when 
pressed with RMB or LMB as seen in the tooltip image next page:

Also, the Viewing Planes toolbar allows you to select any projection direction as 
the viewing direction (try both LMB and RMB clicks):
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Try also Clipping functionality through 
the  Clipping  Tab  to  look  inside  the 
model. The Clipping Tab is opened with 
the           icon. The clipped area can be 
displayed  with  different  ways,  like  with 
wireframe or transparent. 
Clipping also enables to extract real time 
slice  information  on  the  model.  Real 
time slices can be copied to the Model 
Tree  for  internal  model  dimensioning 
with  the  Edit/  >  Save  Clip  curves 
command. 

Selecting objects

On the left hand side of the Dimensions Expert window you can see the Model 
Tree tab.

This tab tells you the current contents of 
the program database. With this file you 
can see one shell (aka node, group) 1. 
dino-connected (Repaired). The node 1. 
includes the correct dino model, as 
indicated by the green icon with the 
shell. The (Repaired) text describes the 
last command run on the surfaces, 
which in this case is repair. 
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If you click the +-icon at the shell 1. it 
will open and display the separate 
triangle surfaces the dino model is 
made of. During the repair process the 
model is subdivided into separate 
surfaces along sharp edges. Triangle 
surfaces are indicated by a yellow 
triangle icon and the operation name 
during which the surface was 
generated, i.e. 1. Repaired for the first 
and biggest triangle surface in the 
model and so forth. 

You can select objects at different levels either directly from the Model Tree with 
LBM  click  or  graphically  from  the  display  area.  For  example,  the  surface  4 
selected from the Model Tree corresponds to the sole of the front right leg of the 
dino model. This is indicated with highlight and green bounding box around the 
selected surface in the display area:

Different objects can be selected also graphically from the display area with LMB. 
On the  right  hand side  of  the  screen you  can see the  Tools  Window which 
includes the Selection mode icons. 
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The Selection mode icons allow you to 
set the graphical selection level to  All,  
Shell,  Surface  or Gaps.  The  default 
mode is shown in the image right and it 
is  the  Shell level.  If  you now click on 
the dino model on the screen with the 
LMB  the  shell  1.  dino-connected 
(Repaired) will be selected in the Model 
Tree. 
Generally,  the Tools Window contains 
handy  shortcuts  to  the  available 
commands  in  the  selected  Operation 
Mode as well as  Help text window for 
the selected object or for the command 
in progress. 

With Dimensions Expert you normally should select an object and then run the 
desired command to it, as seen in the next lesson. 
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Lesson 2 - Splitting and Combining STL
One of the most common tasks with 3D Printing is to split a large model into 
smaller pieces to fit into the build area. This lesson shows you how to split large 
STL models for 3D printing and Rapid Prototyping. Building a very tall  part is 
more expensive than building two shorter parts simultaneously. Also, the building 
area may not be large enough for a very big part. Correct joining of the split parts 
is ensured by adding guiding pins to the models.

Splitting the dino model

Start  by  inputting  the  DeskArtes  geometry  file  DinoOk.3de in  the 
Tutorials/GeomFiles directory. Give the File > Open command. During the input 
you are prompted if the previous  dino-connected model should be stored into .
3de (DeskArtes proprietary format) file. You should press No when prompted for 
it and continue to the file Open window. Set the correct  File of type (.3de) and 
select the DionOk.3de file for input. 
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The file includes a correct triangulation for the familiar  dino model. You should 
accept the proposed units and  go directly to the  Print Preparation  mode by 
pressing the 

button in the Operation Mode Window. You should see the following dino model: 

with the Print Preparation Tab on the right hand side of the screen.

The  Print  Preparation  Tab  gives 
shortcuts  to  the  mostly  used  print 
preparation  commands,  like  split  and 
connect. The Help Text provides context 
sensitive help to the commands. 
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Select node 1. dino (Repaired) by clicking it with the LBM in the Model Tree. 
Before  the  splitting  we  must  take  a  correct  view  to  the  model  because  the 
splitting plane is generated by extruding a user defined split polygon away from 
the  viewer.  With  3D  Printing  the  correct  way  normally  is  to  split  the  model 
perpendicular to the z-axis to make the part lower. Thus, take a view from the x-
axis direction with View > Ortho View > Front (+X)  (       + LMB).

The splitting is started with command Print Preparation > Split. The system 
prompts you to take the correct view direction if no yet set: 

When the view is correct you  can press Continue or Cancel to quit. You may 
hide this window permanently if necessary by ticking the “Don't show this window 
in the future”. 
The system asks you if you wish to use a  Polyline (linear), Curved split line or 
Coordinate value, select Polyline. After pressing OK that the system goes into 
the curve edit mode where you can define the shape of the splitting surface.
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Now you can draw the shape for the splitting surface. Draw a horizontal line by 
giving two points with the LMB clearly outside of the dino model as seen in 
the image below: 

The curve editing is finished by pressing the RMB or ESC key. When finished 
the model is split along the plane defined with the polyline. After a while the result 
is available in the Model Tree. You can select the upper part with LMB click on 
the shell 1. a-dino (Split) to highlight it. 
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The two halves are named with  a- and  b- prefixes to distinguish between the 
shells above the split line and below the split line.

Creating the pins

The separate parts of the model could now be positioned and stored into .stl files 
for 3D Printing. However, the precise joining of the ready parts would be difficult 
or impossible. To be able to position the parts accurately we shall add pins in the 
models to connect them together after finishing the build.
First we will locate the necessary primitives (sphere, cone, cylinder) which will 
connect the two parts together. We need a nice view to point the pins on the 
screen to start with. Here we are also using the shaded+wireframe view mode 
available with the         icon.
Rotate the model, erase the screen and display the lower part of the dino, 
shell  2. b-dino (Split).  Zoom in to  the front  end of  the model  to  be able to 
accurately position the connectors with the next command.
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The pins are now created with the Print Preparation > Connect command or 
using the Print Preparation Tab shortcut

After the command is given, it is possible to give the shape and the size for the 
pin to be created. Set Diameter and Length both to 10.0, as seen below: 

The pins are positioned with LMB clicks on the display area on top of the dino 
model. Give two locations, the positions for the pins should look similar to the 
image below when  ready.  Note  that  you  can use the  MMB zoom and MMB 
rotation to change the view point when locating the connectors. 
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If a connector location is not correct you can remove it by clicking on the red 
indicator  box  again.  Then  reposition  with  another  LMB  click  on  the  correct 
location. 
When ready Press OK to generate the connectors. After a while you will see 
the connectors added to the selected shell: 

Corresponding holes are automatically created to the a-dino-connector shell. You 
should  move  the  shells  apart  from  each  other  with  the  Transform  menu 
commands prior to outputting the model for 3D Printing. 
You can save both files into the same STL file by selecting the Model Tree root 
All. Anyhow, you normally wan to build and position the parts separately in the 
3D Printer. For that select each shell separately and output it to a proper STL file 
with File > Save As command.  
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Further Reading 
This Dimensions Expert 8.1: Quick Start Guide should give you the skills to verify 
and repair models with simple errors for 3D Printing using Dimensions Expert. 
Model splitting for build with systems with smaller build areas when compared to 
the part size is also presented.  
This Quick Start Guide is the first in a set of tutorials covering different aspects of 
model  repair,  coloring and print preparation. The tutorials are available in the 
software distribution package through the Help > Tutorial Documents menu: 

● Dimensions Expert 8.1: Tutorial 1 – Working with 3D Models  introduces 
basic  automatic  repair  and  model  manipulation  for  STL  files  with 
Dimensions Expert software in more detail. Estimated completion time is 
1-2 hours. 

● STL  and  VRML  repair  examples  gives  more  advanced  model  repair 
examples  to  master  the  use  of  Dimensions  Expert  repair  functions. 
Estimated completion time is 3 hours.

Additional information can be found in the Handling Faceted Models section of 
the On-line Help pages. These pages contain information on verifying, repairing 
and splitting. 
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